Do Not Upgrade to your TomTom to 7.481

0

I just updated to the latest version of the firmware and now the TomTom hangs when search for a POI. “Tomtom Forums”:http://www.tomtomforums.com/showthread.php?s=85c58a2c63c0f09ae1ed4748c4fcfe4d&t=8710 reports lots of these problems. Basically, when searching a POI, it hangs on “Wait a moment…” amd then when you try to Find, you get a grey screen.

The above was for the 920, but this is with my 720. Sigh. Sometimes updating to the latest isn’t such a good idea particularly when there isn’t an obvious way to downgrade.

They report the easiest fix is to “roll back” to firmware before 7.481 and restore all directories. Of course I didn’t back anything up, so I’m SOL. One fellow reports downgrarding to 7.221 works. Apparently these are known issues with 7.481 and there isn’t a fix

Here is how you downgrade:

# http://www.oldboy.me.uk/TomTomUpdates/ Go here to find 7.221
# Decompress this to a directory on your computer
# If you have XP, then you can just drag it all to the root of your TomTom (don’t use their cheesy application, do it from the Explorer)
# If you have a Mac, then you have to go to each subdirectory and do this because the Mac replaces an entire directory with the new one, while you just want all the files in them updated.

One fellow did report that deleting some of the POIs may help (I have buckets of POIs from various sites).

http://www.tomtomforums.com/showthread.php?t=8710&page=3 while TomTom support claims that you can fix this by going to http://www.tomtom.com/6221 and downloading the TomTom Clear Flash Tool. Run it three times and this fixes the problems. Most other folks think that this is baloney and won’t work.

Related Posts