So frustrating Mac Mail Search fails may need to delete all Spotlight indices

0

This is the first time I’ve had this problem, but basically Spotlight indexing is working, but Mac Mail doesn’t seem to ever find anything. I’m not the first person with this problem. But the fix doesn’t seem to work. Doing a rebuild and then deleting the index doesn’t help.
I also tried just deleting all the data in ~/Library/Mail/V4 which forces a complete reload, but that doesn’t work either. Argh!
Another suggestion was to sign in and out of iCloud?!
Or you can rebuild your entire Spotlight index since Mac Mail uses it (although this feels like a Mac Mail bug since Spotlight works fine). Now that this actually generated an error saying that it could not remove the entire disk. This looks like a terrible error:
Privacy List Error (null)
Looks like a bug and now typing the terminal line mdutil -E / returns a /: No Index Yikes!
Now it looks like there is something really wrong with Spotlight, so I tried the draconian sudo rm -rf ./Spotlight-V100 but amazing, this doesn’t change any indexing and I still get no index messages. Argh!
What’s needed is an actual reboot (which they don’t mention). But after reboot, I do get the indexing message at the Spotlight icon. I don’t know if this will help but worth a try.
And Eureka it works. Looks like net, net, Spotlight somehow got confused. I’m not sure if I had to do a complete reindex, but the fact I was getting (null) messages is not a good sign

Related Posts

© All Right Reserved