More Mavericks incompatibilities.. XBMC

0

Well we already had Drobo Pro, so now here is XBMC. YOu need a pre build of Frodo 12.2 for it to work

Related Posts

© All Right Reserved